SQL0286N A default table space could not be found with a page size of at least “4096” that authorization ID “user1” is authorized to use. SQLSTATE=42727
This was after a DECLARE GLOBAL TEMPORARY TABLE type of statement
I had a look at the users permissions.They were
CREATE SCHEMA user1 ;
grant connect on database to user user1;
grant ALTERIN,CREATEIN,DROPIN on schema user1 to user user1;
The next test step was to create a tablespace for temprary tables and give USE permissions to “user1”
CREATE USER TEMPORARY TABLESPACE usr_tbsp MANAGED BY AUTOMATIC
and issue permissions :
GRANT USE OF TABLESPACE usr_tbsp TO USER user1
This solved the problem
Leave a Reply