No memory available in Application Heap

The plaform used in the diagnosis for the No memory available in Application Heap

Red Hat Linux 4.6
DB2 9.1.04 ESE 32 bit
Websphere Business Monitor

The problem was identified as users attempted to log on to business space. The logon was successfull but no widgets were returning. The following error message was extracted from the db2diag.log  of the DB2 server instance

2010-05-06-13.18.38.713664+060 I19708680G531 LEVEL: Error
PID : 26600 TID : 3085903552 PROC : db2agent (MYDB) 0
INSTANCE: db2myInstance NODE : 000 DB : MYDB
APPHDL : 0-273 APPID: 10.110.221.80.6330.100506030314
AUTHID : db2myInstance
FUNCTION: DB2 UDB, access plan manager, sqlra_load_var, probe:25
RETCODE : ZRC=0x8B0F0001=-1961951231=SQLO_NOMEM_APPH
 "No memory available in 'Application Heap'"
 DIA8301C No memory available in the application heap.

The resoution path was :

Attempt 1 – double APPLHEAPZ from 256 to 512 – result: same error

Attempt 2 – double APPLHEAPZ from  512 to 1024 – result: same error

Attempt 3 – upgrade to Fix Pack 4 : Rerun all logon types – OK

Attempt 4 – upgrade to Fix Pack 4, decrease APPLHEAPSZ to 256 (default setting) : Rerun all logon types – OK, This was attempt was “false positive” , as I had misdiagnosed the release of other resources on the system . The problem promptly reapperead after some usage

Attempt 5 – db2 UPDATE DB CFG FOR MYDB USING APPLHEAPSZ 4000

Problem fixed !

Author: Jack Vamvas

Leave a Reply

Discover more from ciquery

Subscribe now to keep reading and get access to the full archive.

Continue reading