There are a number of PIDs – which have been causing high amounts of CPU usage since last Sunday
which are repeatedly throwing the following error
LEVEL: Error (OS)
PID : 7564
TID : 3086759616
PROC : db2pfchr 0
INSTANCE: db2myInstance
NODE : 000
FUNCTION: DB2 UDB, oper system services, sqloCSemP, probe:1
CALLED : OS, -, unspecified_system_function
SERR: EIDRM (43)
2008-12-15-10.59.40.404497+000 E2190G306
Looking at these processes , they are taking about 70% of the CPU continiously.
These are errors , and as I have the Notify Level set at Level 2 they are reported into the db2diag.log file for
this particular instance.
Every other instance is OK .
The schedule of work to solve the problem was :
1)Stop Websphere Portal
2)stop MY_STANDBY_SERVERdb2myInstance
3)stop MY_PRIMARY_SERVERdb2MyInstance –
As instance
cd sqllib/bin
db2_kill <db2myInstance>
ipclean <db2myInstance>
As root
ps -ef | grep <db2myInstance> (This will check for any remaining instance processes which may still be running)
kill -9 <PID> (terminate any remaining processes belonging to the instance)
4)start MY_STANDBY_SERVERdb2myInstance . This will allow these servers to be picked up when the Primary Server starts
5)start MY_PRIMARY_SERVERdb2MyInstance as Primary servers
6)Start Web sphere portal –
7)Confirm everything is OK
The cause of the problen was : on Sunday ,the instance “db2myInstance” was being backed up via TSM , through a daily backup maintenance
schedule.The TSM server was not contactable – this caused the prefetcher to attempt buffer allocation.
Ref:Jack Vamvas
TrackBack
TrackBack URL for this entry:
http://www.typepad.com/services/trackback/6a00d834539b6d69e2010536870d66970b
Listed below are links to weblogs that reference db2diag.log file filling:
There are a number of PIDs – which have been causing high amounts of CPU usage since last Sunday
which are repeatedly throwing the following error
LEVEL: Error (OS)
PID : 7564
TID : 3086759616
PROC : db2pfchr 0
INSTANCE: db2myInstance
NODE : 000
FUNCTION: DB2 UDB, oper system services, sqloCSemP, probe:1
CALLED : OS, -, unspecified_system_function
SERR: EIDRM (43)
2008-12-15-10.59.40.404497+000 E2190G306
Looking at these processes , they are taking about 70% of the CPU continiously.
These are errors , and as I have the Notify Level set at Level 2 they are reported into the db2diag.log file for
this particular instance.
Every other instance is OK .
The schedule of work to solve the problem was :
1)Stop Websphere Portal
2)stop MY_STANDBY_SERVERdb2myInstance
3)stop MY_PRIMARY_SERVERdb2MyInstance –
As instance
cd sqllib/bin
db2_kill <db2myInstance>
ipclean <db2myInstance>
As root
ps -ef | grep <db2myInstance> (This will check for any remaining instance processes which may still be running)
kill -9 <PID> (terminate any remaining processes belonging to the instance)
4)start MY_STANDBY_SERVERdb2myInstance . This will allow these servers to be picked up when the Primary Server starts
5)start MY_PRIMARY_SERVERdb2MyInstance as Primary servers
6)Start Web sphere portal –
7)Confirm everything is OK
The cause of the problen was : on Sunday ,the instance “db2myInstance” was being backed up via TSM , through a daily backup maintenance
schedule.The TSM server was not contactable – this caused the prefetcher to attempt buffer allocation.
Ref:Jack Vamvas